In short
- CVE-2024-42470 is a CRITICAL (CVSS 9.1) vulnerability affecting org.openhab.ui.bundles:org.openhab.ui.cometvisu, openhab (openhab).
- Chance of exploitation in the next 30 days (EPSS): 0.52%, higher than 44.5% of all vulnerabilities.
- Fix: update to 4.2.1 or later.
Description
Several endpoints in the CometVisu add-on of openHAB don't require authentication. This makes it possible for unauthenticated attackers to modify or to steal sensitive data.
Impact
This issue may lead to sensitive Information Disclosure.
NVD description
openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. Several endpoints in versions prior to 4.2.1 of the CometVisu add-on of openHAB don't require authentication. This makes it possible for unauthenticated attackers to modify or to steal sensitive data. This issue may lead to sensitive information disclosure. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.
More vulnerabilities in org.openhab.ui.bundles:org.openhab.ui.cometvisu
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free