In short
- CVE-2024-42469 is a CRITICAL (CVSS 9.8) vulnerability affecting org.openhab.ui.bundles:org.openhab.ui.cometvisu, openhab (openhab).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.5% of all vulnerabilities.
- Fix: update to 4.2.1 or later.
Description
CometVisu's file system endpoints don't require authentication and additionally the endpoint to update an existing file is susceptible to path traversal. This makes it possible for an attacker to overwrite existing files on the openHAB instance. If the overwritten file is a shell script that is executed at a later time this vulnerability can allow remote code execution by an attacker.
This vulnerability was discovered with the help of CodeQL's Uncontrolled data used in path expression query.
Impact
This issue may lead up to Remote Code Execution (RCE).
NVD description
openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. Prior to version 4.2.1, CometVisu's file system endpoints don't require authentication and additionally the endpoint to update an existing file is susceptible to path traversal. This makes it possible for an attacker to overwrite existing files on the openHAB instance. If the overwritten file is a shell script that is executed at a later time, this vulnerability can allow remote code execution by an attacker. Users should upgrade to version 4.2.1 to receive a patch.
More vulnerabilities in org.openhab.ui.bundles:org.openhab.ui.cometvisu
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free