In short
- CVE-2024-5321 is a MEDIUM (CVSS 6.1) vulnerability affecting k8s.io/kubernetes.
- Chance of exploitation in the next 30 days (EPSS): 0.31%, higher than 24.1% of all vulnerabilities.
- Fix: update to 1.28.12, 1.29.7, 1.30.3, 1.27.16 or later.
| Package | Affected versions | Patched versions |
|---|
| k8s.io/kubernetes Go | ≥ 1.28.0, < 1.28.12≥ 1.29.0, < 1.29.7≥ 1.30.0, < 1.30.3< 1.27.16
| 1.28.121.29.71.30.31.27.16
|
Description
A security issue was discovered in Kubernetes clusters with Windows nodes where BUILTIN\Users may be able to read container logs and NT AUTHORITY\Authenticated Users may be able to modify container logs.
NVD description
A security issue was discovered in Kubernetes clusters with Windows nodes where BUILTIN\Users may be able to read container logs and NT AUTHORITY\Authenticated Users may be able to modify container logs.
More vulnerabilities in k8s.io/kubernetes
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free