In short
- CVE-2025-1974 is a CRITICAL (CVSS 9.8) vulnerability affecting k8s.io/ingress-nginx.
- Chance of exploitation in the next 30 days (EPSS): 99.4%, higher than 99.9% of all vulnerabilities.
- Fix: update to 1.12.1, 1.11.5 or later.
| Package | Affected versions | Patched versions |
|---|
| k8s.io/ingress-nginx Go | ≥ 1.12.0-beta.0, < 1.12.1< 1.11.5all versions
| 1.12.11.11.5
|
Description
A security issue was discovered in Kubernetes where under certain conditions, an unauthenticated attacker with access to the pod network can achieve arbitrary code execution in the context of the ingress-nginx controller. This can lead to disclosure of Secrets accessible to the controller. (Note that in the default installation, the controller can access all Secrets cluster-wide.)
NVD description
A security issue was discovered in Kubernetes where under certain conditions, an unauthenticated attacker with access to the pod network can achieve arbitrary code execution in the context of the ingress-nginx controller. This can lead to disclosure of Secrets accessible to the controller. (Note that in the default installation, the controller can access all Secrets cluster-wide.)
More vulnerabilities in k8s.io/ingress-nginx
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free