In short
- CVE-2025-22867 is a HIGH (CVSS 7.5) vulnerability affecting toolchain.
- Chance of exploitation in the next 30 days (EPSS): 0.65%, higher than 50.9% of all vulnerabilities.
- Fix: update to 1.24.0-rc.3 or later.
| Package | Affected versions | Patched versions |
|---|
| toolchain Go | ≥ 1.24.0-rc.2, < 1.24.0-rc.3
| 1.24.0-rc.3
|
Description
On Darwin, building a Go module which contains CGO can trigger arbitrary code execution when using the Apple version of ld, due to usage of the @executable_path, @loader_path, or @rpath special values in a "#cgo LDFLAGS" directive. This issue only affected go1.24rc2.
NVD description
On Darwin, building a Go module which contains CGO can trigger arbitrary code execution when using the Apple version of ld, due to usage of the @executable_path, @loader_path, or @rpath special values in a "#cgo LDFLAGS" directive. This issue only affected go1.24rc2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free