In short
- CVE-2025-24513 is a MEDIUM (CVSS 4.8) vulnerability affecting k8s.io/ingress-nginx.
- Chance of exploitation in the next 30 days (EPSS): 3.3%, higher than 88.6% of all vulnerabilities.
- Fix: update to 1.12.1, 1.11.5 or later.
| Package | Affected versions | Patched versions |
|---|
| k8s.io/ingress-nginx Go | ≥ 1.12.0-beta.0, < 1.12.1< 1.11.5all versions
| 1.12.11.11.5
|
Description
A security issue was discovered in ingress-nginx where attacker-provided data are included in a filename by the ingress-nginx Admission Controller feature, resulting in directory traversal within the container. This could result in denial of service, or when combined with other vulnerabilities, limited disclosure of Secret objects from the cluster.
NVD description
A security issue was discovered in ingress-nginx https://github.com/kubernetes/ingress-nginx where attacker-provided data are included in a filename by the ingress-nginx Admission Controller feature, resulting in directory traversal within the container. This could result in denial of service, or when combined with other vulnerabilities, limited disclosure of Secret objects from the cluster.
More vulnerabilities in k8s.io/ingress-nginx
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free