In short
- CVE-2025-44163 is a MEDIUM (CVSS 6.3) vulnerability affecting billz/raspap-webgui, raspap-webgui (raspap).
- Chance of exploitation in the next 30 days (EPSS): 0.60%, higher than 48.9% of all vulnerabilities.
- Fix: update to 3.3.6 or later.
Description
RaspAP raspap-webgui 3.3.1 is vulnerable to Directory Traversal in ajax/networking/get_wgkey.php. An authenticated attacker can send a crafted POST request with a path traversal payload in the entity parameter to overwrite arbitrary files writable by the web server via abuse of the tee command used in shell execution.
NVD description
RaspAP raspap-webgui 3.3.1 is vulnerable to Directory Traversal in ajax/networking/get_wgkey.php. An authenticated attacker can send a crafted POST request with a path traversal payload in the `entity` parameter to overwrite arbitrary files writable by the web server via abuse of the `tee` command used in shell execution.
More vulnerabilities in billz/raspap-webgui
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free