In short
- CVE-2025-51487 is a MEDIUM (CVSS 4.5) vulnerability affecting moonshine/moonshine, moonshine (moonshine).
- Chance of exploitation in the next 30 days (EPSS): 0.43%, higher than 37.5% of all vulnerabilities.
- Fix: update to 3.12.4, 3.12.5 or later.
Description
A stored cross-site scripting (XSS) vulnerability in the Create Article function of MoonShine v3.12.3 allows attackers to execute arbitrary web scripts or HTML via injecting a crafted payload into the Link parameter.
NVD description
A Stored Cross-Site Scripting (XSS) vulnerability exists in MoonShine version < 3.12.5, allowing to execute arbitrary JavaScript by using "javascript:" payload, instead of the expected HTTPS protocol, in the CutCode Link parameter when creating/updating a new Article.
More vulnerabilities in moonshine/moonshine
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free