In short
- CVE-2025-51488 is a MEDIUM (CVSS 4.9) vulnerability affecting moonshine/moonshine, moonshine (moonshine).
- Chance of exploitation in the next 30 days (EPSS): 0.56%, higher than 46.8% of all vulnerabilities.
- Fix: update to 3.12.14, 3.12.5 or later.
Description
A stored cross-site scripting (XSS) vulnerability in the Create Admin function of MoonShine v3.12.3 allows attackers to execute arbitrary web scripts or HTML via injecting a crafted payload into the Name parameter.
NVD description
A Stored Cross-Site Scripting (XSS) vulnerability exists in MoonShine version < 3.12.4, allowing remote attackers to store and execute arbitrary JavaScript by including a malicious HTML payload in the Name parameter when creating a new Admin.
More vulnerabilities in moonshine/moonshine
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free