In short
- CVE-2025-5302 is a HIGH (CVSS 8.6) vulnerability affecting llama-index-core.
- Chance of exploitation in the next 30 days (EPSS): 0.29%, higher than 21.1% of all vulnerabilities.
- Fix: update to 0.12.38 or later.
Description
A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.
NVD description
A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.
More vulnerabilities in llama-index-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free