In short
- CVE-2025-7647 is a HIGH (CVSS 7.3) vulnerability affecting llama-index-core.
- Chance of exploitation in the next 30 days (EPSS): 0.15%, higher than 4.2% of all vulnerabilities.
- Fix: update to 0.13.0 or later.
Description
The llama-index-core package, up to version 0.12.44, contains a vulnerability in the get_cache_dir() function where a predictable, hardcoded directory path /tmp/llama_index is used on Linux systems without proper security controls. This vulnerability allows attackers on multi-user systems to steal proprietary models, poison cached embeddings, or conduct symlink attacks. The issue affects all Linux deployments where multiple users share the same system. The vulnerability is classified under CWE-379, CWE-377, and CWE-367, indicating insecure temporary file creation and potential race conditions.
NVD description
The llama-index-core package, up to version 0.12.44, contains a vulnerability in the `get_cache_dir()` function where a predictable, hardcoded directory path `/tmp/llama_index` is used on Linux systems without proper security controls. This vulnerability allows attackers on multi-user systems to steal proprietary models, poison cached embeddings, or conduct symlink attacks. The issue affects all Linux deployments where multiple users share the same system. The vulnerability is classified under CWE-379, CWE-377, and CWE-367, indicating insecure temporary file creation and potential race conditions.
More vulnerabilities in llama-index-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free