In short
- CVE-2025-6208 is a MEDIUM (CVSS 5.3) vulnerability affecting llama-index-core.
- Chance of exploitation in the next 30 days (EPSS): 0.41%, higher than 35.8% of all vulnerabilities.
- Fix: update to 0.12.41 or later.
Description
The SimpleDirectoryReader component in llama_index.core version 0.12.23 suffers from uncontrolled memory consumption due to a resource management flaw. The vulnerability arises because the user-specified file limit (num_files_limit) is applied after all files in a directory are loaded into memory. This can lead to memory exhaustion and degraded performance, particularly in environments with limited resources. The issue is resolved in version 0.12.41.
NVD description
The `SimpleDirectoryReader` component in `llama_index.core` version 0.12.23 suffers from uncontrolled memory consumption due to a resource management flaw. The vulnerability arises because the user-specified file limit (`num_files_limit`) is applied after all files in a directory are loaded into memory. This can lead to memory exhaustion and degraded performance, particularly in environments with limited resources. The issue is resolved in version 0.12.41.
More vulnerabilities in llama-index-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free