In short
- CVE-2025-57106 is a HIGH (CVSS 7.5) vulnerability affecting vtk, vtk (vtk).
- Chance of exploitation in the next 30 days (EPSS): 0.43%, higher than 37.2% of all vulnerabilities.
- Fix: update to 9.5.1 or later.
| Package | Affected versions | Patched versions |
|---|
| vtk PyPI | < 9.5.1
| 9.5.1
|
| vtk | ≤ 9.5.0
| No fix yet |
Description
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.
NVD description
Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free