In short
- CVE-2025-57107 is a HIGH (CVSS 7.1) vulnerability affecting vtk, vtk (vtk).
- Chance of exploitation in the next 30 days (EPSS): 0.18%, higher than 7.5% of all vulnerabilities.
- Fix: update to 9.5.1 or later.
| Package | Affected versions | Patched versions |
|---|
| vtk PyPI | < 9.5.1
| 9.5.1
|
| vtk | ≤ 9.5.0
| No fix yet |
Description
Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.
NVD description
Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free