In short
- CVE-2025-57108 is a CRITICAL (CVSS 9.8) vulnerability affecting vtk, vtk (vtk).
- Chance of exploitation in the next 30 days (EPSS): 0.40%, higher than 33.7% of all vulnerabilities.
- Fix: update to 9.5.1 or later.
| Package | Affected versions | Patched versions |
|---|
| vtk PyPI | < 9.5.1
| 9.5.1
|
| vtk | ≤ 9.5.0
| No fix yet |
Description
Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap use-after-free vulnerability in vtkGLTFDocumentLoader. The vulnerability manifests during mesh object copy operations where vector members are accessed after the underlying memory has been freed, specifically when handling GLTF files with corrupted or invalid mesh reference structures.
NVD description
Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap use-after-free vulnerability in vtkGLTFDocumentLoader. The vulnerability manifests during mesh object copy operations where vector members are accessed after the underlying memory has been freed, specifically when handling GLTF files with corrupted or invalid mesh reference structures.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free