In short
- CVE-2025-7053 is a MEDIUM (CVSS 6.1) vulnerability affecting cockpit-hq/cockpit, cockpit (agentejo).
- Chance of exploitation in the next 30 days (EPSS): 0.35%, higher than 29.2% of all vulnerabilities.
- Fix: update to 2.11.4 or later.
Description
A vulnerability was found in Cockpit versions up to 2.11.3. This issue affects some unknown processing instances of the file /system/users/save. The manipulation of the arguments "name" or "email" leads to cross-site scripting. The attack may be initiated remotely. Upgrading to version 2.11.4 will address this issue. It is recommended to upgrade the affected component. The vendor was contacted early about this disclosure and acted accordingly. A patch and new release were made available very quickly.
NVD description
A vulnerability was found in Cockpit up to 2.11.3. It has been rated as problematic. This issue affects some unknown processing of the file /system/users/save. The manipulation of the argument name/email leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.11.4 is able to address this issue. The patch is named bdcd5e3bc651c0839c7eea807f3eb6af856dbc76. It is recommended to upgrade the affected component. The vendor was contacted early about this disclosure and acted very professional. A patch and new release was made available very quickly.
More vulnerabilities in cockpit-hq/cockpit
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free