In short
- CVE-2026-3219 is a MEDIUM (CVSS 4.6) vulnerability affecting pip.
- Chance of exploitation in the next 30 days (EPSS): 0.14%, higher than 3.7% of all vulnerabilities.
- Fix: update to 26.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pip PyPI | < 26.1
| 26.1
|
Description
pip handles concatenated tar and ZIP files as ZIP files regardless of filename or whether a file is both a tar and ZIP file. This behavior could result in confusing installation behavior, such as installing "incorrect" files according to the filename of the archive. New behavior only proceeds with installation if the file identifies uniquely as a ZIP or tar archive, not as both.
NVD description
pip handles concatenated tar and ZIP files as ZIP files regardless of filename or whether a file is both a tar and ZIP file. This behavior could result in confusing installation behavior, such as installing "incorrect" files according to the filename of the archive. New behavior only proceeds with installation if the file identifies uniquely as a ZIP or tar archive, not as both.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free