In short
- CVE-2026-8643 is a MEDIUM (CVSS 5.5) vulnerability affecting pip, pip (pypa).
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 25.0% of all vulnerabilities.
- Fix: update to 26.1.2 or later.
| Package | Affected versions | Patched versions |
|---|
| pip PyPI | < 26.1.2
| 26.1.2
|
| pip | < 26.1.2
| 26.1.2
|
Description
pip would treat console_scripts and gui_scripts as paths instead of file names without sanitizing the resolved absolute path to the installation directory, leading to entry points being installed outside the installation directory.
NVD description
pip would treat console_scripts and gui_scripts as paths instead of file names without sanitizing the resolved absolute path to the installation directory, leading to entry points being installed outside the installation directory.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free