In short
- CVE-2026-6357 is a MEDIUM (CVSS 5.3) vulnerability affecting pip.
- Chance of exploitation in the next 30 days (EPSS): 0.14%, higher than 3.2% of all vulnerabilities.
- Fix: update to 26.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pip PyPI | < 26.1
| 26.1
|
Description
pip prior to version 26.1 would run self-update check functionality after installing wheel files which required importing well-known Python modules names. These module imports were intentionally deferred to increase startup time of the pip CLI. The patch changes self-update functionality to run before wheels are installed to prevent newly-installed modules from being imported shortly after the installation of a wheel package. Users should still review package contents prior to installation.
NVD description
pip prior to version 26.1 would run self-update check functionality after installing wheel files which required importing well-known Python modules names. These module imports were intentionally deferred to increase startup time of the pip CLI. The patch changes self-update functionality to run before wheels are installed to prevent newly-installed modules from being imported shortly after the installation of a wheel package. Users should still review package contents prior to installation.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free