Kurz gesagt
- CVE-2026-22250 ist eine Schwachstelle (MITTEL (CVSS 5.5)) in wlc, wlc (weblate).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.15%, höher als bei 4.5% aller Schwachstellen.
- Abhilfe: auf 1.17.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| wlc PyPI | < 1.17.0
| 1.17.0
|
| wlc | < 1.17.0
| 1.17.0
|
Description
Impact
The SSL verification would be skipped for some crafted URLs.
Patches
Workarounds
Avoid using untrusted wlc configurations, as that might cause insecure connections.
References
This issue was reported to us by wh1zee via HackerOne.
NVD description
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, the SSL verification would be skipped for some crafted URLs. This vulnerability is fixed in 1.17.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free