Kurz gesagt
- CVE-2026-42150 ist eine Schwachstelle (MITTEL (CVSS 4.8)) in wlc, wlc (weblate).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.17%, höher als bei 6.8% aller Schwachstellen.
- Abhilfe: auf 2.0.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| wlc PyPI | < 2.0.0
| 2.0.0
|
| wlc | < 2.0.0
| 2.0.0
|
Description
Impact
The HTML output format in wlc embeds API response data into HTML without escaping, allowing cross-site scripting when the output is rendered in a browser.
Patches
Workarounds
The only vulnerable code path is HTML output which is opt-in.
References
Weblate thanks @fg0x0 for reporting this on GitHub.
NVD description
wlc is a Weblate command-line client using Weblate's REST API. Prior to version 2.0.0, the HTML output format in wlc embeds API response data into HTML without escaping, allowing cross-site scripting when the output is rendered in a browser. This issue has been patched in version 2.0.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free