Kurz gesagt
- CVE-2026-23535 ist eine Schwachstelle (HOCH (CVSS 8.0)) in wlc, wlc (weblate).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.39%, höher als bei 32.8% aller Schwachstellen.
- Abhilfe: auf 1.17.2 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| wlc PyPI | < 1.17.2
| 1.17.2
|
| wlc | < 1.17.2
| 1.17.2
|
Description
Impact
Multi-translation download could write to an arbitrary location when instructed by a crafted server.
Patches
Workarounds
Do not use wlc download with untrusted servers.
References
This issue was reported to us by wh1zee via HackerOne.
NVD description
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free