En resumen
- CVE-2022-37021 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a org.apache.geode:geode-core, geode (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.6%, mayor que el 85.6% de las vulnerabilidades.
- Solución: actualizar a 1.13.5, 1.14.1, 1.12.16 o posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.geode:geode-core Maven | ≥ 1.13.0, < 1.13.5≥ 1.14.0, < 1.14.1< 1.12.16
| 1.13.51.14.11.12.16
|
| geode | = 1.14.0≥ 1.13.0, ≤ 1.13.4≤ 1.12.5
| No fix yet |
Description
Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.
NVD description
Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.
Más vulnerabilidades de org.apache.geode:geode-core
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free