En resumen
- CVE-2022-37022 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a org.apache.geode:geode-core, geode (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.5%, mayor que el 74.4% de las vulnerabilidades.
- Solución: actualizar a 1.15.0 o posterior.
Description
Apache Geode versions up to 1.12.2 and 1.13.2 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 11. Any user wishing to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15. Use of 1.15 on Java 11 will automatically protect JMX over RMI against deserialization attacks. This should have no impact on performance since it only affects JMX/RMI which Gfsh uses to communicate with the JMX Manager which is hosted on a Locator.
NVD description
Apache Geode versions up to 1.12.2 and 1.13.2 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 11. Any user wishing to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15. Use of 1.15 on Java 11 will automatically protect JMX over RMI against deserialization attacks. This should have no impact on performance since it only affects JMX/RMI which Gfsh uses to communicate with the JMX Manager which is hosted on a Locator.
Más vulnerabilidades de org.apache.geode:geode-core
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free