En resumen
- CVE-2022-37023 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a org.apache.geode:geode-core, geode (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.8%, mayor que el 78.3% de las vulnerabilidades.
- Solución: actualizar a 1.15.0 o posterior.
Description
Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.
NVD description
Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.
Más vulnerabilidades de org.apache.geode:geode-core
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free