En resumen
- CVE-2025-29847 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a org.apache.linkis:linkis, linkis (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.87%, mayor que el 59.0% de las vulnerabilidades.
- Solución: actualizar a 1.8.0 o posterior.
Description
A vulnerability in Apache Linkis.
Problem Description
When using the JDBC engine and data source functionality, if the URL parameter configured on the frontend has undergone multiple rounds of URL encoding, it may bypass the system's checks. This bypass can trigger a vulnerability that allows unauthorized access to system files via JDBC parameters.
Scope of Impact
This issue affects Apache Linkis: from 1.3.0 through 1.7.0.
Severity level
moderate
Solution
Continuously check if the connection information contains the "%" character; if it does, perform URL decoding.
Users are recommended to upgrade to version 1.8.0, which fixes the issue.
More questions about this vulnerability can be discussed here: https://lists.apache.org/[email protected]:2025-9:cve
NVD description
A vulnerability in Apache Linkis.
Problem Description
When using the JDBC engine and da
When using the JDBC engine and data source functionality, if the URL parameter configured on the frontend has undergone multiple rounds of URL encoding, it may bypass the system's checks. This bypass can trigger a vulnerability that allows unauthorized access to system files via JDBC parameters.
Scope of Impact
This issue affects Apache Linkis: from 1.3.0 through 1.7.0.
Severity level
moderate
Solution
Continuously check if the connection information contains the "%" character; if it does, perform URL decoding.
Users are recommended to upgrade to version 1.8.0, which fixes the issue.
More questions about this vulnerability can be discussed here: https://lists.apache.org/[email protected]:2025-9:cve
Más vulnerabilidades de org.apache.linkis:linkis
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free