En resumen
- CVE-2026-27121 es una vulnerabilidad MEDIO (CVSS 5.4) que afecta a svelte (svelte), svelte.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.22%, mayor que el 12.6% de las vulnerabilidades.
- Solución: actualizar a 5.51.5 o posterior.
| Package | Affected versions | Patched versions |
|---|
| svelte | < 5.51.5
| 5.51.5
|
| svelte npm | < 5.51.5
| 5.51.5
|
Description
Versions of svelte prior to 5.51.5 are vulnerable to cross-site scripting (XSS) during server-side rendering. When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers.
NVD description
svelte performance oriented web framework. Versions of svelte prior to 5.51.5 are vulnerable to cross-site scripting (XSS) during server-side rendering. When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers. This vulnerability is fixed in 5.51.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free