En bref
- CVE-2018-11796 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant org.apache.tika:tika-core, tika (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 7.5%, plus élevée que 94.5% des vulnérabilités.
- Correctif : mettre à jour vers 1.19.1 ou plus récent.
Description
In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.
NVD description
In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.
Autres vulnérabilités de org.apache.tika:tika-core
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free