En bref
- CVE-2022-29189 est une vulnérabilité MOYENNE (CVSS 5.3) touchant github.com/pion/dtls, github.com/pion/dtls/v2, dtls (pion).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.1%, plus élevée que 82.2% des vulnérabilités.
- Correctif : mettre à jour vers 2.1.4 ou plus récent.
Description
Impact
A buffer that was used for inbound network traffic had no upper limit. Pion DTLS would buffer all network traffic from the remote user until the handshake completes or times out. An attacker could exploit this to cause excessive memory usage.
Patches
Upgrade to Pion DTLS v2.1.4
Workarounds
No workarounds available, upgrade to Pion DTLS v2.1.4
References
Thank you to Juho Nurminen and the Mattermost team for discovering and reporting this.
For more information
If you have any questions or comments about this advisory:
NVD description
Pion DTLS is a Go implementation of Datagram Transport Layer Security. Prior to version 2.1.4, a buffer that was used for inbound network traffic had no upper limit. Pion DTLS would buffer all network traffic from the remote user until the handshake completes or timed out. An attacker could exploit this to cause excessive memory usage. Version 2.1.4 contains a patch for this issue. There are currently no known workarounds available.
Autres vulnérabilités de github.com/pion/dtls
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free