En bref
- CVE-2022-29190 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant github.com/pion/dtls, github.com/pion/dtls/v2, dtls (pion).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.7%, plus élevée que 77.9% des vulnérabilités.
- Correctif : mettre à jour vers 2.1.4 ou plus récent.
Description
Impact
An attacker can send packets that will send Pion DTLS into an infinite loop when processing.
Patches
Upgrade to Pion DTLS v2.1.4
Workarounds
No workarounds available, upgrade to Pion DTLS v2.1.4
References
Thank you to Juho Nurminen and the Mattermost team for discovering and reporting this.
For more information
If you have any questions or comments about this advisory:
NVD description
Pion DTLS is a Go implementation of Datagram Transport Layer Security. Prior to version 2.1.4, an attacker can send packets that sends Pion DTLS into an infinite loop when processing. Version 2.1.4 contains a patch for this issue. There are currently no known workarounds available.
Autres vulnérabilités de github.com/pion/dtls
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free