En bref
- CVE-2022-29222 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant github.com/pion/dtls, github.com/pion/dtls/v2, dtls (pion).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.83%, plus élevée que 57.5% des vulnérabilités.
- Correctif : mettre à jour vers 2.1.5 ou plus récent.
Description
Impact
A DTLS Client could provide a Certificate that it doesn't posses the private key for and Pion DTLS wouldn't reject it.
This issue affects users that are using Client certificates only. The connection itself is still secure. The Certificate provided by clients can't be trusted when using a Pion DTLS server prior to v2.1.5
Patches
Upgrade to Pion DTLS v2.1.5
Workarounds
No workarounds available, upgrade to Pion DTLS v2.1.5
References
Thank you to Juho Nurminen and the Mattermost team for discovering and reporting this.
For more information
If you have any questions or comments about this advisory:
NVD description
Pion DTLS is a Go implementation of Datagram Transport Layer Security. Prior to version 2.1.5, a DTLS Client could provide a Certificate that it doesn't posses the private key for and Pion DTLS wouldn't reject it. This issue affects users that are using Client certificates only. The connection itself is still secure. The Certificate provided by clients can't be trusted when using a Pion DTLS server prior to version 2.1.5. Users should upgrade to version 2.1.5 to receive a patch. There are currently no known workarounds.
Autres vulnérabilités de github.com/pion/dtls
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free