En bref
- CVE-2022-39944 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant org.apache.linkis:linkis, linkis (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.2%, plus élevée que 82.9% des vulnérabilités.
- Correctif : mettre à jour vers 1.3.0 ou plus récent.
Description
In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. This issue is patched in version 1.3.0, and users are recommended to upgrade.
NVD description
In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.2.0 will be affected, We recommend users to update to 1.3.0.
Autres vulnérabilités de org.apache.linkis:linkis
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free