En bref
- CVE-2022-44645 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant org.apache.linkis:linkis, linkis (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.9%, plus élevée que 80.1% des vulnérabilités.
- Correctif : mettre à jour vers 1.3.1 ou plus récent.
Description
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users to upgrade the version of Linkis to version 1.3.1.
NVD description
In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected.
We recommend users to upgrade the version of Linkis to version 1.3.1.
Autres vulnérabilités de org.apache.linkis:linkis
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free