En bref
- CVE-2026-106510 est une vulnérabilité ÉLEVÉE (CVSS 7.7) touchant backstage (linuxfoundation), backstage plugin-techdocs-node (linuxfoundation), @backstage/plugin-techdocs-node.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.48%, plus élevée que 41.3% des vulnérabilités.
- Correctif : mettre à jour vers 1.54.6, 1.50.5, 1.15.4, 1.14.6 ou plus récent.
Description
Impact
An authenticated user who can register catalog entities can provide a crafted mkdocs.yml causing arbitrary OS command execution on the TechDocs build host when the docs are built.
Patches
Patched in @backstage/plugin-techdocs-node, version 1.15.4.
Workarounds
If you cannot upgrade immediately:
- Switch to
techdocs.builder: external to isolate TechDocs builds in a container.
- Restrict who can register catalog entities with TechDocs annotations.
- Audit existing catalog entities for suspicious
markdown_extensions values in their mkdocs.yml files.
NVD description
Backstage is an open framework for building developer portals. Prior to 1.14.6, the @backstage/plugin-techdocs-node package is affected by remote code execution via crafted markdown_extensions in techdocs mkdocs.yml. An authenticated user who can register catalog entities can provide a crafted mkdocs.yml causing arbitrary OS command execution on the TechDocs build host when the docs are built. This issue is fixed in versions 1.14.6 and 1.15.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free