In breve
- CVE-2026-44212 è una vulnerabilità CRITICO (CVSS 9.3) che riguarda prestashop/prestashop.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.43%, superiore al 36.8% delle vulnerabilità.
- Correzione: aggiornare a 9.1.1, 8.2.6 o successiva.
Description
Impact
This is a stored Cross-site Scripting (XSS) vulnerability in the PrestaShop back-office Customer Service view.
An unauthenticated attacker can submit the public Contact Us form with a malicious email address. The payload is stored in the database and executed when a back-office employee opens the affected customer thread, enabling session hijacking and full back-office takeover.
Patches
Patched in PrestaShop 8.2.6 and 9.1.1.
Workarounds
None.
Resources
- Reported by Savio at Doyensec (
[email protected]) in collaboration with Anthropic Research.
NVD description
PrestaShop is an open source e-commerce web application. Prior to 8.2.6 and 9.1.1, there is a stored Cross-Site Scripting (XSS) vulnerability in the PrestaShop back-office Customer Service view. An unauthenticated attacker can submit the public Contact Us form with a malicious email address. The payload is stored in the database and executed when a back-office employee opens the affected customer thread, enabling session hijacking and full back-office takeover. This vulnerability is fixed in 8.2.6 and 9.1.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free