要点
- CVE-2015-9243 は hapi (hapijs), hapi に影響する深刻度「中」 (CVSS 5.9) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.0%(全脆弱性の 63.5% より高い)。
- 対処:11.1.4 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| hapi | < 11.1.4
| 11.1.4
|
| hapi npm | < 11.1.4
| 11.1.4
|
概要
Versions of hapi prior to 11.1.4 are affected by a vulnerability that causes route-level CORS configuration to override connection-level or server-level CORS defaults. This may result in a situation where CORS permissions are less restrictive than intended.
Recommendation
Update hapi to version 11.1.4 or later.
NVD の説明
When server level, connection level or route level CORS configurations in hapi node module before 11.1.4 are combined and when a higher level config included security restrictions (like origin), a higher level config that included security restrictions (like origin) would have those restrictions overridden by less restrictive defaults (e.g. origin defaults to all origins `*`).
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン