要点
- CVE-2017-16013 は hapi (hapijs), hapi に影響する深刻度「高」 (CVSS 7.5) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.6%(全脆弱性の 75.2% より高い)。
- 対処:16.1.1 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| hapi | ≥ 15.0.0, ≤ 16.1.0
| 修正版なし |
| hapi npm | ≥ 15.0.0, < 16.1.1
| 16.1.1
|
概要
Affected versions of hapi will crash or lock the event loop when a malformed accept-encoding header is recieved.
Recommendation
Update to version 16.1.1 or later.
NVD の説明
hapi is a web and services application framework. When hapi >= 15.0.0 <= 16.1.0 encounters a malformed `accept-encoding` header an uncaught exception is thrown. This may cause hapi to crash or to hang the client connection until the timeout period is reached.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン