要点
- CVE-2019-16762 は slpjs (simpleledger), slpjs に影響する深刻度「中」 (CVSS 6.1) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.1%(全脆弱性の 65.7% より高い)。
- 対処:0.21.4 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| slpjs | < 0.21.4
| 0.21.4
|
| slpjs npm | < 0.21.4
| 0.21.4
|
概要
Validator parsing discrepancy due to string encoding
Impact
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus.
Patches
All versions > 0.21.3 are patched.
Workarounds
Upgrade to any version >= 0.21.4.
References
The bug was located and fixed here.
For more information
If you have any questions or comments about this advisory:
NVD の説明
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン