要点
- CVE-2021-21408 は smarty/smarty, smarty (smarty) に影響する深刻度「高」 (CVSS 8.8) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):2.1%(全脆弱性の 81.5% より高い)。
- 対処:4.0.3, 3.1.43 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| smarty/smarty Packagist | ≥ 4.0.0, < 4.0.3< 3.1.43
| 4.0.33.1.43
|
| smarty | ≥ 4.0.0, < 4.0.3< 3.1.43
| 4.0.33.1.43
|
概要
Impact
Template authors could run restricted static php methods.
Patches
Please upgrade to 3.1.40 or higher.
References
See the documentation on Smarty security features on the static_classes access filter.
For more information
If you have any questions or comments about this advisory please open an issue in the Smarty repo
NVD の説明
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.43 and 4.0.3, template authors could run restricted static php methods. Users should upgrade to version 3.1.43 or 4.0.3 to receive a patch.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン