要点
- CVE-2021-41265 は flask-appbuilder, flask-appbuilder (dpgaspar) に影響する深刻度「高」 (CVSS 8.8) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.3%(全脆弱性の 70.8% より高い)。
- 対処:3.3.4 以降に更新してください。
概要
Impact
Improper authentication on the REST API. Allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. Only affects non database authentication types, and new REST API endpoints.
Patches
Upgrade to Flask-AppBuilder 3.3.4
For more information
If you have any questions or comments about this advisory:
NVD の説明
Flask-AppBuilder is a development framework built on top of Flask. Verions prior to 3.3.4 contain an improper authentication vulnerability in the REST API. The issue allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. This only affects non database authentication types and new REST API endpoints. Users should upgrade to Flask-AppBuilder 3.3.4 to receive a patch.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン