要点
- CVE-2022-23494 は TinyMCE, tinymce/tinymce, tinymce (tiny) に影響する深刻度「中」 (CVSS 6.1) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.0%(全脆弱性の 63.3% より高い)。
- 対処:6.3.1, 5.10.7 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| TinyMCE NuGet | ≥ 6.0.0, < 6.3.1< 5.10.7
| 6.3.15.10.7
|
| tinymce/tinymce Packagist | ≥ 6.0.0, < 6.3.1< 5.10.7
| 6.3.15.10.7
|
| tinymce | ≥ 6.0.0, < 6.3.1< 5.10.7
| 6.3.15.10.7
|
| tinymce npm | ≥ 6.0.0, < 6.3.1< 5.10.7
| 6.3.15.10.7
|
概要
Impact
A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the image plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user.
Patches
This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements.
Fix
To avoid this vulnerability:
- Upgrade to TinyMCE 5.10.7 or higher for TinyMCE 5.x.
- Upgrade to TinyMCE 6.3.1 or higher for TinyMCE 6.x.
Workaround
To reduce the impact of this vulnerability:
- Ensure the the
images_upload_handler returns a valid value as per the images_upload_handler documentation.
References
For more information
If you have any questions or comments about this advisory:
NVD の説明
tinymce is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the `image` plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user. This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements. Users are advised to upgrade to either 5.10.7 or 6.3.1. Users unable to upgrade may ensure the the `images_upload_handler` returns a valid value as per the images_upload_handler documentation.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン