| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| TinyMCE | ≥ 6.8.0, < 7.1.0 | 7.1.0 |
| tinymce/tinymce | ≥ 6.8.0, < 7.1.0 | 7.1.0 |
| tinymce | ≥ 6.8.0, < 7.1.0 | 7.1.0 |
| tinymce | ≥ 6.8.0, < 7.1.0 | 7.1.0 |
TinyMCE 6.8.x contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested <svg> elements can bypass attribute sanitization and execute arbitrary JavaScript.
This issue affects TinyMCE 6.8.x-7.0.x. The vulnerability is fixed in TinyMCE 7.1.0 and later.
No official workaround available.
Tiny thanks maple3142 (https://maple3142.net) of DEVCORE for their help identifying this vulnerability.
Fix introduced in TinyMCE 7.1.0 though a rewrite of code causing the vulnerability.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン