要点
- CVE-2024-38357 は TinyMCE, tinymce/tinymce, django-tinymce に影響する深刻度「中」 (CVSS 6.1) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.53%(全脆弱性の 44.8% より高い)。
- 対処:6.8.4, 7.2.0, 5.11.0, 4.1.0 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| TinyMCE NuGet | ≥ 6.0.0, < 6.8.4≥ 7.0.0, < 7.2.0< 5.11.0
| 6.8.47.2.05.11.0
|
| tinymce/tinymce Packagist | ≥ 6.0.0, < 6.8.4≥ 7.0.0, < 7.2.0< 5.11.0
| 6.8.47.2.05.11.0
|
| django-tinymce PyPI | < 4.1.0
| 4.1.0
|
| tinymce npm | ≥ 6.0.0, < 6.8.4≥ 7.0.0, < 7.2.0< 5.11.0
| 6.8.47.2.05.11.0
|
概要
Impact
A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content parsing code. This allowed specially crafted noscript elements containing malicious code to be executed when that content was loaded into the editor.
Patches
This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that content within noscript elements are properly parsed.
Fix
To avoid this vulnerability:
- Upgrade to TinyMCE 7.2.0 or higher.
- Upgrade to TinyMCE 6.8.4 or higher for TinyMCE 6.x.
- Upgrade to TinyMCE 5.11.0 LTS or higher for TinyMCE 5.x (only available as part of commercial long-term support contract).
Acknowledgements
Tiny thanks Malav Khatri and another reporter for their help identifying this vulnerability.
References
For more information
If you have any questions or comments about this advisory:
NVD の説明
TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content parsing code. This allowed specially crafted noscript elements containing malicious code to be executed when that content was loaded into the editor. This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that content within noscript elements are properly parsed. Users are advised to upgrade. There are no known workarounds for this vulnerability.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン