要点
- CVE-2022-31177 は flask-appbuilder, flask-appbuilder (dpgaspar) に影響する深刻度「低」 (CVSS 2.7) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.77%(全脆弱性の 55.5% より高い)。
- 対処:4.1.3 以降に更新してください。
概要
Impact
An authenticated Admin user could craft HTTP requests to filter users by their salted and hashed passwords strings. These filters could be made by using partial hashed password strings. The response would not include the hashed passwords, but an attacker could infer partial password hashes and their respective users.
Only when using AUTH_DB database authentication option.
Patches
Fixed on 4.1.3
For more information
If you have any questions or comments about this advisory:
NVD の説明
Flask-AppBuilder is an application development framework built on top of Flask python framework. In versions prior to 4.1.3 an authenticated Admin user could query other users by their salted and hashed passwords strings. These filters could be made by using partial hashed password strings. The response would not include the hashed passwords, but an attacker could infer partial password hashes and their respective users. This issue has been fixed in version 4.1.3. Users are advised to upgrade. There are no known workarounds for this issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン