| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| cakephp/cakephp | ≥ 4.2.0, < 4.2.12≥ 4.3.0, < 4.3.11≥ 4.4.0, < 4.4.10 | 4.2.124.3.114.4.10 |
| cakephp/database | ≥ 4.2.0, < 4.2.12≥ 4.3.0, < 4.3.11≥ 4.4.0, < 4.4.10 | 4.2.124.3.114.4.10 |
| cakephp | ≥ 4.2.0, < 4.2.12≥ 4.3.0, < 4.3.11≥ 4.4.0, < 4.4.10 | 4.2.124.3.114.4.10 |
The Cake\Database\Query::limit() and Cake\Database\Query::offset() methods are vulnerable to SQL injection if passed un-sanitized user request data.
This issue has been fixed in 4.2.12, 4.3.11, 4.4.10
Using CakePHP's Pagination library will mitigate this issue, as will validating or casting parameters to these methods.
https://bakery.cakephp.org/2023/01/06/cakephp_4211_4311_4410_released.html
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン