要点
- CVE-2023-45819 は TinyMCE, tinymce/tinymce, tinymce (tiny) に影響する深刻度「中」 (CVSS 6.1) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.63%(全脆弱性の 50.4% より高い)。
- 対処:6.7.1, 5.10.8 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| TinyMCE NuGet | ≥ 6.0.0, < 6.7.1< 5.10.8
| 6.7.15.10.8
|
| tinymce/tinymce Packagist | ≥ 6.0.0, < 6.7.1< 5.10.8
| 6.7.15.10.8
|
| tinymce | ≥ 6.0.0, < 6.7.1< 5.10.8
| 6.7.15.10.8
|
| tinymce npm | ≥ 6.0.0, < 6.7.1< 5.10.8
| 6.7.15.10.8
|
概要
Impact
A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s Notification Manager API. The vulnerability exploits TinyMCE's unfiltered notification system, which is used in error handling. The conditions for this exploit requires carefully crafted malicious content to have been inserted into the editor and a notification to have been triggered.
When a notification was opened, the HTML within the text argument was displayed unfiltered in the notification. The vulnerability allowed arbitrary JavaScript execution when an notification presented in the TinyMCE UI for the current user. This issue could also be exploited by any integration which uses a TinyMCE notification to display unfiltered HTML content.
Patches
This vulnerability has been patched in TinyMCE 5.10.8 and TinyMCE 6.7.1 by ensuring that the HTML displayed in the notification is sanitized, preventing the exploit.
Fix
To avoid this vulnerability:
- Upgrade to TinyMCE 5.10.8 or higher for TinyMCE 5.x.
- Upgrade to TinyMCE 6.7.1 or higher for TinyMCE 6.x.
References
For more information
If you have any questions or comments about this advisory:
NVD の説明
TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s Notification Manager API. The vulnerability exploits TinyMCE's unfiltered notification system, which is used in error handling. The conditions for this exploit requires carefully crafted malicious content to have been inserted into the editor and a notification to have been triggered. When a notification was opened, the HTML within the text argument was displayed unfiltered in the notification. The vulnerability allowed arbitrary JavaScript execution when an notification presented in the TinyMCE UI for the current user. This issue could also be exploited by any integration which uses a TinyMCE notification to display unfiltered HTML content. This vulnerability has been patched in TinyMCE 5.10.8 and TinyMCE 6.7.1 by ensuring that the HTML displayed in the notification is sanitized, preventing the exploit. Users are advised to upgrade. There are no known workarounds for this vulnerability.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン