| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| fuxa | ≥ 1.2.8, < 1.2.11 | 1.2.11 |
| fuxa-server | ≥ 1.2.8, < 1.2.11 | 1.2.11 |
Description An authentication bypass vulnerability in FUXA allows an unauthenticated, remote attacker to execute arbitrary code on the server when the Node-RED plugin is enabled. This affects FUXA version 1.2.8 through version 1.2.10. This has been patched in FUXA version 1.2.11.
This affects all deployments with the Node-RED plugin enabled, including those with runtime.settings.secureEnabled set to true.
Exploitation allows an unauthenticated, remote attacker to send a specially crafted request to the /nodered/flows endpoint to bypass authentication checks, granting the attacker administrative access to the Node-RED deployment API. By submitting a malicious flow configuration, an attacker can execute arbitrary code in the context of the FUXA service. Depending on deployment configuration and permissions, this may lead to full system compromise and could further expose connected ICS/SCADA environments to follow-on actions.
This issue has been patched in FUXA version 1.2.11. Users are strongly encouraged to update to the latest available release.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン