| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| fuxa | ≥ 1.2.8, < 1.2.11 | 1.2.11 |
| fuxa-server | ≥ 1.2.8, < 1.2.11 | 1.2.11 |
An authorization bypass vulnerability in the FUXA allows an unauthenticated, remote attacker to create and modify arbitrary schedulers, exposing connected ICS/SCADA environments to follow-on actions. This vulnerability affects FUXA version 1.2.8 through version 1.2.10. This has been patched in FUXA version 1.2.11.
This affects all deployments, including those with runtime.settings.secureEnabled set to true.
Exploitation allows an unauthenticated, remote attacker to automatically authenticate as guest and create, modify or delete schedules. These schedules can be configured to trigger immediately or cyclically, forcing connected devices to specific states or values, or executing existing scripts on the server.
This issue has been patched in FUXA version 1.2.11. Users are strongly encouraged to update to the latest available release.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン