| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.apache.activemq:activemq-all | ≥ 6.0.0, < 6.2.5< 5.19.6 | 6.2.55.19.6 |
| org.apache.activemq:activemq-broker | ≥ 6.0.0, < 6.2.5< 5.19.6 | 6.2.55.19.6 |
| org.apache.activemq:apache-activemq | ≥ 6.0.0, < 6.2.5< 5.19.6 | 6.2.55.19.6 |
| activemq | ≥ 6.0.0, < 6.2.5< 5.19.6 | 6.2.55.19.6 |
| activemq broker | ≥ 6.0.0, < 6.2.5< 5.19.6 | 6.2.55.19.6 |
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ, Apache ActiveMQ Broker, Apache ActiveMQ All.
An authenticated attacker can use the admin web console page to construct a malicious broker name that bypasses name validation to include an xbean binding that can be later used by a VM transport to load a remote Spring XML application. The attacker can then use the DestinationView mbean to send a message to trigger a VM transport creation that will reference this malicious broker name which can lead to loading the malicious Spring XML context file.
Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec().
This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ All: before 5.19.6, from 6.0.0 before 6.2.5.
Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン