要点
- CVE-2026-42150 は wlc, wlc (weblate) に影響する深刻度「中」 (CVSS 4.8) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.17%(全脆弱性の 6.8% より高い)。
- 対処:2.0.0 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| wlc PyPI | < 2.0.0
| 2.0.0
|
| wlc | < 2.0.0
| 2.0.0
|
概要
Impact
The HTML output format in wlc embeds API response data into HTML without escaping, allowing cross-site scripting when the output is rendered in a browser.
Patches
Workarounds
The only vulnerable code path is HTML output which is opt-in.
References
Weblate thanks @fg0x0 for reporting this on GitHub.
NVD の説明
wlc is a Weblate command-line client using Weblate's REST API. Prior to version 2.0.0, the HTML output format in wlc embeds API response data into HTML without escaping, allowing cross-site scripting when the output is rendered in a browser. This issue has been patched in version 2.0.0.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン